Вопрос по информатике:
Написать программу на языке Си для вычисления значений следующих выражений:
a=5, c=5
a=a+b-2
c=c+1, d=c-a+d
a=a*c, c=c-1
a=a/10, c=c/2, b=b-1, d=d*(c+b+a)
Выражения, записанные в одной строке, записывать одним оператором-выражением. Переменные c и d объявить как целые, переменные a и b – как вещественные. Значения переменных b и d вводить с клавиатуры. После вычисления каждого выражения выводить на экран значения всех переменных.
- 10.05.2018 23:58
- Информатика
- remove_red_eye 915
- thumb_up 14
Ответы и объяснения 1
Я конечно не особо программист, но это вроде работает
#include
int main(){
float a=5,c=5;
int b,d;
printf("Здравствуйте!Введите 2 числа:\n");
scanf("%d",&b); scanf("%d",&d);
a += b-2;
d += c-a-1;
a = a*c-1;
a = a/10;
c = c/2;
b--;
d = d*(c+b+a);
printf("В итоге получилось:%F,%F,%d,%d",&a,&b,&c,&d);
return 0;
}
- 11.05.2018 16:33
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.