Вопрос по информатике:
Напишите программу, которая вводит возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год" "года" или "лет". Например "21 год" "22 года" "25 лет"
PascalABC.NET
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 23.11.2016 18:37
- Информатика
- remove_red_eye 8861
- thumb_up 27
Ответы и объяснения 2
var a:integer;
begin
read(a);
case a of 1,21,31,41,51,61,71,81,91,101:writeln(a,' год'); 2,3,4,22,23,24,32,33,34,42,43,44,52,53,54,62,63,64,72,73,74,82,83,84,92,93,94,102,103,104:writeln(a,' года'); 5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,25,26,27,28,29,30,35,36,37,38,39,40,45,46,47,48,49,50,55,56,57,58,59,60,65,66,67,68,69,70,75,76,77,78,79,80,85,86,88,89,90,105,106,107,108,109,110,115,116,117,118,119,120:writeln(a,' лет');
end;
end.
Программа есть в приложении, просто скачай.
- 24.11.2016 10:34
- thumb_up 20
Var
A:integer;
Begin
WriteLn('Введи возраст');
Read(A);
if (A>9)and(A<20) then WriteLn(A,' Лет')
else
Case A mod 10 of
1:Write(A,' Год ');
2..4:Write(A,' Года ');
0,5..9:Write(A,' Лет ');
End
End.
- 25.11.2016 19:05
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.