Вопрос по информатике:
Составить программу ( Паскаль) для 5 целых чисел, найти максимальное из них
P.S ТОЛЬКО с помощью If Then Else (должно быть коротко). Прошу помогите пожалуйста!!(
- 09.09.2018 03:45
- Информатика
- remove_red_eye 16654
- thumb_up 21
Ответы и объяснения 1
Var
n1,n2,n3,n4,n5:integer;
begin
Readln(n1,n2,n3,n4,n5);
If (n1>n2) and (n1>n3) and (n1>n4) and (n1>n5) then
writeln('Максимальное число: ',n1)
else If (n2>n1) and (n2>n3) and (n2>n4) and (n2>n5) then
writeln('Максимальное число: ',n2)
else If (n3>n1) and (n3>n2) and (n3>n4) and (n3>n5) then
writeln('Максимальное число: ',n3)
else If (n4>n1) and (n4>n3) and (n4>n2) and (n4>n5) then
writeln('Максимальное число: ',n4)
else
writeln('Максимальное число: ',n5);
end.
- 01.01.1970 00:00
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.