Вопрос по информатике:
N - factorial это проезведение всех чисел от 1 до n. для заданного числа N определите сколько нулей в конце десятичной записи n - factorial
- 05.02.2016 01:25
- Информатика
- remove_red_eye 16381
- thumb_up 35
Ответы и объяснения 1
Program 1;
var n,k2,k5,i,a:integer;
begin
write('n=');
read(n);
k2:=0;k5:=0;
for i:=2 to n do begin a:=i;
if a mod 2=0 then while a>=2 do
begin
a:=a div 2;
k2:=k2+1;
end;
a:=i;
if a mod 5=0 then while a>=5 do begin a:=a div 5;
k5:=k5+1; end; end;
if k2
readln
end.
- 06.02.2016 02:50
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.