Вопрос по информатике:
Помогите с программой в паскале!
На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т. д. и выдайте результат. В выходных данных всегда должно быть 9 чисел.
ВХОДНЫЕ ДАННЫЕ
Дана последовательность цифр от 1 до 9, заканчивающаяся нулем.
ВЫХОДНЫЕ ДАННЫЕ
Выведите через пробел количество единиц, двоек, …, девяток в этой последовательности.
ПРИМЕРЫ
ВВОД ВЫВОД
1 1 4 1 5 8 6 3 5 1 0
4 0 1 1 2 1 0 1 0
- 25.05.2018 08:34
- Информатика
- remove_red_eye 15826
- thumb_up 9
Ответы и объяснения 1
Var a: array [1..9] of word;
i: longint;
begin
for i := 1 to 9 do a[i] := 0;
repeat
read(i);
if i 0 then inc(a[i])
until i = 0;
for i := 1 to 9 do write(a[i], ' ')
end.
- 26.05.2018 12:16
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.