Вопрос по информатике:
Составить программу вычисления суммы цифр двухзначного числа "a".Значение "а",введите с клавиатуры.ПОМОГИТЕ!!!Срочно надо(Буду вам очень признательна *_*
- 20.09.2015 00:10
- Информатика
- remove_red_eye 7932
- thumb_up 26
Ответы и объяснения 2
Должно работать и для двухзначного и для 3ехзначного и для 99999значного
var
a,sum:integer;
begin
readln(a);
while a>0 do
begin
sum:=sum+a mod 10;
a:=a div 10;
end;
writeln(sum);
end.
- 21.09.2015 04:40
- thumb_up 48
Pascal ABC
Var
A:integer;
Begin
Write('A = ');Read(A);
Write(A div 10,'+',A mod 10,' = ',(A div 10)+(A mod 10))
End.
- 22.09.2015 13:12
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.