Вопрос по информатике:
Составить программу, позволяющую определить, есть ли среди цифр задорного целого трехзначного числа Х четные?
- 18.01.2018 18:57
- Информатика
- remove_red_eye 4084
- thumb_up 10
Ответы и объяснения 2
Var
x,ed,des,sot:integer;
Begin
Readln(x);
ed:=x mod 10;
des:=x div 10 mod 10;
sot:=x div 100 mod 10;
x:=0;
if sot mod 10=1 then x:=x+0 else x:=x+1;
if des mod 10=1 then x:=x+0 else x:=x+1;
if ed mod 10=1 then x:=x+0 else x:=x+1;
if x>0 then writeln('Есть') else writeln('Нет');
end.
- 19.01.2018 05:13
- thumb_up 8
Var
n,d1,d10,d100:integer;
begin
Write('Введите натуральное трехзначное число: '); Read(n);
d1:=n mod 10; d100:=n div 100;
d10:=(n div 10) mod 10;
if (d1 mod 2 = 0) or (d10 mod 2=0) or (d100 mod 2=0)
then Writeln('Есть четная цифра')
else Writeln('Нет четных цифр')
end.
- 20.01.2018 12:34
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.