Вопрос по информатике:
Нужно написать программу, что бы буквы заменялись на на "заглавные", а не те, что стоят перед ними в английском алфавите. PascalABC
Program eX_1;
var s: String;
n, i, b, j: longint;
c: char;
begin
writeln('Введи текст из сообщения выше:');
readln(s);
for i:=length(s) downto 1 do
if s[i] in ['a'..'z'] then s[i]:=Upcase(s[i])
else if s[i] in ['A'..'Z'] then s[i]:=chr(ord(s[i])+32)
else if s[i] in ['0'..'9'] then delete(s,i,1);
write(s);
end.
- 16.09.2017 19:18
- Информатика
- remove_red_eye 8474
- thumb_up 24
Ответы и объяснения 1
Program eX_1;
var s: String;n, i, b, j: longint;c: char;
begin
writeln('Введи текст из сообщения выше:');
readln(s);for i:=length(s) downto 1 do
if s[i] in ['b'..'z'] then s[i]:=chr(ord(s[i])-1)
else if s[i]='a'then s[i]:='z' ;
write(s);
end.
- 17.09.2017 01:35
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.