Вопрос по информатике:
Составить программу, которая подсчитывает общее количество общих количественных целых пятизначных чисел, которые удовлетворяют условиям:
a) abcde - пятизначное число
b) a, b, c, d - разные цифры
c) ac-ce=a-b+c+d+e
d) e - четное число
В ответе запишите только число.
- 04.01.2015 18:50
- Информатика
- remove_red_eye 4733
- thumb_up 16
Ответы и объяснения 1
Текст программы (Pascal)
var
a,b,c,d,e:byte;
k:integer;
begin
k:=0;
for a:=1 to 9 do begin
for b:=0 to 9 do
if ba then begin
for c:=0 to 9 do
if (ca) and (cb) then begin
for d:=0 to 9 do
if (da) and (db) and (dc) then begin
e:=0;
repeat
if a*c-c*e=a-b+c+d+e then Inc(k);
e:=e+2
until e<9
end
end
end
end;
Writeln(k)
end.
Тестовое решение:
190
- 05.01.2015 12:40
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.