Вопрос по информатике:
Битовый код для точки с координатами ( x , y ) состоит из четырех битов, каждый из которых показывает, входит ли точка в одну из заштрихованных областей. Первый по счёту бит определяет, входит ли точка в область а (см. рисунок), второй третий и четвёртый биты отвечают за попадание точки соответственно в области б , в и г . Напишите программу, которая выводит битовый код точки с заданными координатами.
- 22.03.2018 00:45
- Информатика
- remove_red_eye 8819
- thumb_up 39
Ответы и объяснения 1
Var x,y: real;
var a,b,c,d:integer;
begin
readln(x,y);
if (y<1) then
write ('1')
else write ('0');
if (y<-x) then
write ('1')
else write ('0');
if sqr(x)+sqr(y)<1 then
write ('1')
else write ('0');
if sqr(x-1)+sqr(y)<1 then
write ('1')
else write ('0');
end.
- 22.03.2018 02:24
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.