Вопрос по информатике:
Помогите написать программу в турбо паскале, а именно:
Протабулировать функцию y=x-пи на отрезке [0;11] с шагом h=1,1. Результаты вычислений вывести на экран в виде таблицы пар чисел x, y. Вычислить модуль разности максимального и минимального значений функции y.
- 07.04.2018 05:22
- Информатика
- remove_red_eye 13178
- thumb_up 38
Ответы и объяснения 1
Uses Crt;
const
pi=3.14159;
var
x,y,h,max,min,d:real;
begin
ClrScr;
max:=-100; min:=100; x:=0; h:=1.1;
while x<=11+h/2 do begin
y:=x-pi;
Writeln(x:10:7,y:12:7);
if max
x:=x+h;
end;
d:=abs(max-min);
Writeln(d:10:7);
ReadKey
end.
Результат выполнения программы:
0.0000000 -3.1415900
1.1000000 -2.0415900
2.2000000 -0.9415900
3.3000000 0.1584100
4.4000000 1.2584100
5.5000000 2.3584100
6.6000000 3.4584100
7.7000000 4.5584100
8.8000000 5.6584100
9.9000000 6.7584100
11.0000000 7.8584100
11.0000000
- 08.04.2018 03:55
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.