Вопрос по информатике:
Прошу помогите
Андрей очень любит ездить по железной дороге. Он садится у окна и внимательно следит за местностью, которую он проезжает. Особенно он обращает внимание на километровые столбы. Каждый столб с километражем, который при делении на 7 дает в остатке 3, он считает «счастливым». Составьте программу, которая бы определяла количество «счастливых» столбов, если во время езды он проезжает столбы с отметками от a до b.
Входные данные1
26 49
Выходные данные1
3
Входные данные2
3 10
Выходные данные2
2
- 06.03.2018 23:05
- Информатика
- remove_red_eye 720
- thumb_up 41
Ответы и объяснения 1
Простой вариант:
var
i, c, a, b : integer;
begin
c := 0;
read (a, b);
for i := a to b do
if (i mod 7 = 3) then
c := c + 1;
write (c);
end.
оптимальный вариант
var
a, b : integer;
begin
read (a, b);
while a mod 7 3 do
a := a + 1;
while b mod 7 3 do
b := b - 1;
if (a <= b) then
write ((b - a) div 7 + 1)
else
write (0);
end.
- 07.03.2018 10:16
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.