Вопрос по информатике:
Составьте алгоритм и напишите программу для того чтобы выяснить является ли введённое шестизначное число счастливым суперсчастливым или обыкновенным. Шестизначное число называют счастливым если сумма первых трёх его цифр равна сумме трёх последних цифр. Число будет называться суперсчастливым если оно во-первых счастливое а во-вторых сумма первых трёх его чисел равна 11 или 22
- 23.04.2018 00:10
- Информатика
- remove_red_eye 12964
- thumb_up 25
Ответы и объяснения 1
Var n:longint;
c1,c2:byte;
s:boolean;
begin
s:=false
readln(n);
c1:=(n mod 10)+((n div 10) mod 10)+((n div 100) mod 10);
c2:=((n div 1000) mod 10) + ((n div 10000) mod 10) + ((n div 100000) mod 10);
if c1=c2 then s:=true;
if s and ((c2=11) or (c2=22)) then writeln('supershastlivoe') else
if s then writeln('shaslivoe') else writeln('prostoe');
end.
- 24.04.2018 09:24
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.