Вопрос по информатике:
Помогите ,пожалуйста , в с++
Написать программу, которая преобразует введенное с клавиатуры двухразрядное шестнадцатеричное число в десятичное.
- 26.05.2018 22:39
- Информатика
- remove_red_eye 6621
- thumb_up 17
Ответы и объяснения 2
Выбирайте любое решение на ваш вкус, первое немного более топорное.
Решение 1.
#include
#include
int main() {
const std::string numbers = "0123456789ABCDEF";
std::string hex = "";
int dec = 0;
std::cin >> hex;
for(int i = 0; i < hex.length(); i++)
dec = 16 * dec + numbers.find(hex[i]);
std::cout << dec;
return 0;
}
Решение 2.
#include
int main() {
int num = 0;
std::cin >> std::hex >> num;
std::cout << num;
return 0;
}
- 28.05.2018 09:13
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.
