Вопрос по информатике:
(На с++)Написать программу. Подсчет нулевых элементов в заданном одномерном массиве.
- 20.07.2017 17:45
- Информатика
- remove_red_eye 2285
- thumb_up 43
Ответы и объяснения 1
Using namespase std;
void main ()
{
setlocale (LC_ALL, "Russian");
int n, k;\\размер массива и счетчик
cout << "Введите количество элементов массива" << endl;
cin >> n;
float *arr = new float[n]; \\создаем динамический массив, т.к. не знаем сколько дано элементов и какие они
\\заполнение массива с клавиатуры
for (int i=0; i
cout << "Введите " << i << "-ый элемент массива" << endl;
cin >> arr[i];
}
\\вывод массива на экран
for (int i=0; i
\\подсчет нулевых элементов
k=0;
for (int i=0; i
if (arr[i] == 0) k++
}
cout << "Количество нулевых элементов в заданном массиве = " << k;
}
- 21.07.2017 19:02
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.