Вопрос по информатике:
Ввести два целочисленныхмассива − по 10 элементов в каждом. Сформировать новый массив, на четных местах которого будут элементы с нечетными индексами из первого массива, а нанечетных – с четными индексами из второго.Написать программу на паскале
- 18.07.2018 07:11
- Информатика
- remove_red_eye 9626
- thumb_up 18
Ответы и объяснения 1
Скрин с результатом работы программы прикрепил.
var a:array[1..10] of integer;
b:array[1..10] of integer;
c:array[1..10] of integer;
i:integer;
begin
write ('Введите массив 1: ');
for i:=1 to 10 do
read (a[i]);
WRITELN;
write ('Введите массив 2: ');
for i:=1 to 10 do
read (b[i]);
WRITELN;
WRITELN;
write ('Массив 3: ');
for i:=1 to 10 do
begin
if i mod 2 0 then c[i]:=b[i+1];
if i mod 2 = 0 then c[i]:=a[i-1];
write (c[i],' ');
end;
end.
- 19.07.2018 23:13
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.