Вопрос по информатике:
Нарисовать блок схему алгоритма и написать программу,которая:
1)Вводит массив А из 10 чисел
2)Заполняет два массива В и С длиной 10
первый элемент массива В равен последнему элементу массива А,второй-предпоследнему,и т.д
массив С=(А+В)/2
3)вывести в столбец А В С
10 6 8
0 -2 -1
- 25.11.2017 10:06
- Информатика
- remove_red_eye 18117
- thumb_up 41
Ответы и объяснения 1
Const
n=10;
var
a,b,c:array[1..n] of real;
i:integer;
begin
Writeln('Введите элементы массива');
for i:=1 to n do Read(a[i]);
Writeln(' A B C');
for i:=1 to n do
begin
b[i]:=a[n-i+1]; c[i]:=(a[i]+b[i])/2;
Writeln(a[i]:7:3,b[i]:7:3,c[i]:7:3)
end
end.
Тестовое решение:
Введите элементы массива
1.26 -0.3 6.18 7 -7.04 -9.9 -1.7 -2.955 1.75 0.245
A B C
1.260 0.245 0.753
-0.300 1.750 0.725
6.180 -2.955 1.613
7.000 -1.700 2.650
-7.040 -9.900 -8.470
-9.900 -7.040 -8.470
-1.700 7.000 2.650
-2.955 6.180 1.613
1.750 -0.300 0.725
0.245 1.260 0.753
Блок-схема во вложении
- 26.11.2017 17:45
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.