Вопрос по информатике:
С клавиатуры вводится произвольная строка, состоящая из символов латинского алфавита. Группы символов, раздельные пробелами, и не имеющие пробелов внутри будем называть словами. Напишите программу, которая заменяет каждое слово строки на его длину. Длина строки не более 100 символов.
Например: Исходная строка: "An example of a string of characters "
Преобразованная строка "2 7 2 1 2 10"
- 09.04.2015 00:27
- Информатика
- remove_red_eye 19619
- thumb_up 36
Ответы и объяснения 1
Pascal
var
s : string;
i,k : integer;
begin
readln (s);
k := 0;
for i := 1 to Length(s) do
begin
if s[i] ' ' then
k := k + 1
else
begin
write (k+s[i]);
k := 0;
end;
end;
end.
- 09.04.2015 09:01
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.