Вопрос по информатике:
46. Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к переполнению (т.е. к результату большему чем 32 767). Если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел. Через Дельфи
- 27.11.2017 02:51
- Информатика
- remove_red_eye 14012
- thumb_up 39
Ответы и объяснения 1
Program Name;
uses crt;
Var
a, b, s :integer;
Begin
Write('введите a ');
readln(a);
Write('введите b ');
readln(b);
S:=a+b;
if s<32767 then
writeln(s)
else
writeln('произошло переполнение');
End.
- 28.11.2017 05:02
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.