Вопрос по информатике:
Написать программу в Pascal.
Из предложения вывести слова с заданным количеством слогов.
- 22.02.2015 00:35
- Информатика
- remove_red_eye 1549
- thumb_up 27
Ответы и объяснения 1
Количество слогов считаем по количеству гласных букв в слове.
Program pr;
uses crt;
var str,s: string;
a,i,j,len,k,kslog: byte;
Begin
Writeln('Введите предложение');
readln(str);
Writeln('Введите кол-во слогов');
readln(k);
Writeln('Слова с ',k,' слогами:');
Writeln;
len:=length(str);
a:=0;
kslog:=0;
for i:=1 to len do
Begin
if (str[i] = ' ') then
Begin
s:=copy(str,i+1,a);
for j:=1 to length(s) do
Begin
if s[j] in ['А','О','У','Э','Ы','Я','Ё','Ю','Е','И','а','о','у','э','ы','я','ё','ю','е','и'] then inc(kslog);
end;
if (k=kslog) then Writeln(s);
kslog:=0;
a:=0;
end
else a:=a+1;
end;
Writeln;
Writeln('Для завершения программы нажмите Enter');
readln;
end.
- 22.02.2015 22:43
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.