Вопрос по информатике:
Составить алгоритм и написать программу на языке Pascal: Алгоритм вычисления значения функции F(n), где n - натуральное число, задан следующими соотношениями:
F(n) = F(n-1)+ F(n/2), при n>1 и n кратно 2 F(n)=f(n-1) + F(n-2) , при n >1 и n не кратно 2 F(1)=1 Чему равно значение функции F(8)?
- 17.10.2017 13:47
- Информатика
- remove_red_eye 3018
- thumb_up 16
Ответы и объяснения 1
function F(n:integer):integer;
begin
if n=1 then F:=1
else
if (n mod 2)=0 then F:=F(n-1)+F(n div 2)
else F:=F(n-1)+F(n-2)
end;
begin
Writeln('F(8)=',F(8))
end.
Результат выполнения программы:
F(8)=24
- 18.10.2017 17:59
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.