Вопрос по информатике:
Помогите написать программу в паскале.
В заданном массиве найти количество чётных чисел. Вывести исходный массив и результат.
- 02.04.2016 15:44
- Информатика
- remove_red_eye 12095
- thumb_up 19
Ответы и объяснения 1
Вариант с вводом элементов:
Program prog;
uses crt;
var a: array [0..999] of integer;
i, k, n: integer;
begin
clrscr;
write('Размер массива n = ');
readln(n);
writeln;
for i:=1 to n do
begin
write('a[',i,'] = ');
readln (a[i]);
end;
for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln;
writeln('Количество четных чисел k = ', k);
end.
Вариант с рандомными элементами:
Program prog;
uses crt;
var a: array [0..999] of integer;
i, k, n: integer;
begin
clrscr;
randomize;
write('Размер массива n = ');
readln(n);
writeln;
for i:=1 to n do
begin
a[i]:=random(100)-50;
writeln('a[',i,'] = ',a[i]);
end;
for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln;
writeln('Количество четных чисел k =' , k);
end.
- 03.04.2016 16:46
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.