Вопрос по информатике:
Задача:
Дан массив из 10 целых чисел,от -20 до 20 .
Напишите программу,заменяющую первый отрицательный элемент массива нулем.
Помогите пожалуйста решить!
- 02.09.2018 04:58
- Информатика
- remove_red_eye 12664
- thumb_up 39
Ответы и объяснения 1
var a:array [1..10] of integer;
i,n,b:integer;
Begin
for i:=1 to 10 do
read(a[i]);
for i:=1 to 10 do
begin
if b=0 then if a[i]<0 then
begin
a[i]:=0;
b:=1;
end;
end;
for i:=1 to 10 do
write(a[i],' ');
End.
- 03.09.2018 06:55
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.