Вопрос по информатике:
Составьте программу, проверяющую есть ли в двумерном массиве A (N,N) столбцы, все элементы которых различны.
- 24.02.2018 09:20
- Информатика
- remove_red_eye 14640
- thumb_up 26
Ответы и объяснения 1
Const n=4;
Var x:array [1..n,1..n] of integer;
k,s,i,j:integer;
begin
randomize;
for i:=1 to n do begin
for j:=1 to n do begin
x[i,j] := random(100);
write(x[i,j]:6);
end;
writeln;
end;
for i := 1 to n do
for j := 1 to n do
for k := j+1 to n do
if x[j,i]=x[k,i]
then
writeln('NO')
else
writeln ('YES');
readln;
end.
- 25.02.2018 07:52
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.