Вопрос по информатике:
Составить программу вычисления суммы мест, на которых в строке, введенной с клавиатуры, стоят согласные буквы. Например в 'строке' сумма мест согласных букв равняется 1+2+3+5+=11
- 14.08.2016 16:22
- Информатика
- remove_red_eye 18615
- thumb_up 29
Ответы и объяснения 1
Var
s,g:string;
sum:integer;
begin
g:='бвгджзйклмнпрстфхцчшщБВГДЖЗЙКЛМНПРСТФХЦЧШЩ';
read(s);
sum:=0;
for var i:=1 to length(s) do
if (pos(s[i],g)>0) then sum:= sum+i;
writeln(sum);
end.
//ABC Pascal
- 15.08.2016 05:18
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.