Вопрос по информатике:
Помогите пожалуйста срочно решить!
1)Написать программу на паскале:Вычислить длину орбиты земли.Радиус орбиты Земли равен 150 млн.км.
2)Написать программу на паскале:Прием на работу идёт на конкурсной основе.Условия приема требуют 20 лет трудового стажа и возраста не более 45 лет.Определить,будет ли человек принят на работу.
3))Написать программу на паскале:Вывести на экран все трехзначные числа ,сумма квадратов цифр которых равна 105.
- 16.02.2018 20:38
- Информатика
- remove_red_eye 1186
- thumb_up 50
Ответы и объяснения 1
Program P1;
const
R=150000000;
begin
Writeln('Длина орбиты Земли составляет ',2*Pi*R:0:0,' км.')
end.
Результат выполнения программы:
Длина орбиты Земли составляет 942477796 км.
program p2;
var
stazh,vozrast:integer;
begin
Write('Введите через пробел стаж и возраст: ');
Readln(stazh,vozrast);
if (stazh>=20) and (vozrast<=45) then Writeln('Принимается')
else Writeln('Не принимается')
end.
Тестовое решение:
Введите через пробел стаж и возраст: 23 50
Не принимается
program p3;
var
i,j,k:integer;
begin
for i:=1 to 9 do
for j:=0 to 9 do
for k:=0 to 9 do
if sqr(i)+sqr(j)+sqr(k)=105
then Write(i,j,k,' ')
end.
Результат выполнения программы:
458 485 548 584 845 854
- 17.02.2018 06:57
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.