Вопрос по информатике:
Написать программу: Гречу, массой х г, рассыпают по пакетам: по а г в каждый. Пакетов может быть неограниченное количество. Сколько гречи будет в последнем заполненном пакете?
Помогите, пожалуйста.
- 05.07.2015 16:04
- Информатика
- remove_red_eye 6805
- thumb_up 44
Ответы и объяснения 1
// Написать программу: Гречу, массой х г, рассыпают по пакетам: по а г в каждый.
//Пакетов может быть неограниченное количество. Сколько гречи будет в
//последнем заполненном пакете?
var x,a : longword;
begin
writeln ('Введите общую массу гречи, в граммах');
readln (x);
writeln ('Введите массу насыпаемой в пакет гречи, в граммах');
readln (a);
writeln ('полных пакетов будет ',(x div a));
if (x mod a)=0 then writeln ('В последнем насыпанном пакете будет ',a,' грамм гречи')
else writeln ('В последнем насыпанном пакете будет ',(x mod a),' грамм гречи');
end.
- 06.07.2015 02:05
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.