Вопрос по информатике:
Нужно написать программу. Найдите сумму цифр не кратных 3 и произведение цифр больших 5 в записи числа.
- 21.07.2015 02:30
- Информатика
- remove_red_eye 6627
- thumb_up 18
Ответы и объяснения 1
var
a,b,s,p : integer;
begin
readln (a);
s := 0;
p := 1;
while a > 0 do
begin
b := a mod 10;
a := a div 10;
if b mod 3 0 then
s := s + b;
if b > 5 then
p := p * b;
end;
if p = 1 then
p := 0;
writeln (s);
writeln (p);
end.
- 22.07.2015 12:49
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.