Вопрос по информатике:
Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения. Паскаль
- 19.08.2018 00:26
- Информатика
- remove_red_eye 2217
- thumb_up 7
Ответы и объяснения 1
Program a1;
var x,y,s: integer;
begin
read (x,y);
write(x,'*',y,'=');
while x>0 do
begin
If ((x mod 2) 0) then s:=s+y;
x:= x div 2;
y:=y+y;
end;
write(s);
writeln();
readln();
end.
Русский способ умножения
- 19.08.2018 05:13
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.