Вопрос по информатике:
Найдите количество целых чисел на
интервале [100;25000], у которых сумма цифр в десятичной и пятеричной системах счисления одинаковые. В ответе укажите целое число без пробелов и знаков препинания, например, 19
- 12.06.2015 16:10
- Информатика
- remove_red_eye 5556
- thumb_up 41
Ответы и объяснения 1
Var a,b: array [100..25000] of integer;
i,k,n,p:integer;
Begin
for i:=100 to 25000 do
begin
b[i]:=i;
a[i]:=i;
n:=0;
while a[i]>0 do
begin
n:=n+(a[i] mod 10);
a[i]:=a[i]div 10;
end;
p:=0;
while b[i]>0 do
begin
p:=p+(b[i] mod 5)
; b[i]:=b[i]div 5;
end;
if(n=p) then inc(k);
end;
writeln(k);
end.
- 13.06.2015 02:46
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.