Вопрос по информатике:
Даны два неравных целых двухзначных числа. Возвести в квадрат большее из этих чисел и удвоить меньшее число. Написать программу для паскаль.
- 03.01.2015 18:09
- Информатика
- remove_red_eye 12986
- thumb_up 37
Ответы и объяснения 1
Это решение при задании вручную этих чисел:
Program sadadasf;
var i,k,l: integer;
begin
Writeln('Введите первое целое двухзначное число:');
readln(i);
Writeln('Введите второе целое двухзначное число:');
readln(k);
If k>i then begin
k:=k*k;
i:=i*2;
end;
If i>k then begin
i:=i*i;
k:=k*2;
end;
Writeln('Первое число:', i);
Writeln('Второе число:', k);
end.
Это решение при задании чисел в самой программе:
Program sadadasf;
var i,k,l: integer;
begin
i:=5;
k:=3;
If k>i then begin
k:=k*k;
i:=i*2;
end;
If i>k then begin
i:=i*i;
k:=k*2;
end;
Writeln('Первое число:', i);
Writeln('Второе число:', k);
end.
- 04.01.2015 14:22
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.