Вопрос по информатике:
Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений.(на паскале)
- 05.12.2017 06:30
- Информатика
- remove_red_eye 19377
- thumb_up 45
Ответы и объяснения 2
Program sadadasf;
var i,l,h,g: integer;
A: Array[1..101] of integer;
begin
For i:=1 to 100 do
begin
l:=random(41)-20;
A[i]:=l;
If l<0 then h:=h+1;
If l>0 then g:=g+1;
end;
Writeln('Количество отрицательных чисел:', h);
Writeln('Количество положительных чисел:', g);
end.
- 07.12.2017 07:21
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.
