Вопрос по информатике:
Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений. (на паскале)
- 18.07.2016 07:01
- Информатика
- remove_red_eye 623
- thumb_up 14
Ответы и объяснения 1
program qq;
const
N=100;
var a: array [1..N] of integer;
i,min,max : integer;
begin
min:=0; max:=0;
cls;
writeln ('Массив [-20;+20]');
for i:=1 to N do begin
A[i]:=random (40)-20;
write (A[i]:4);
if A[i] < 0 then
min:=min+A[i]
else max:=max+A[i];
end;
writeln;writeln;
writeln ('Cумма положительных элементов: ', max);
writeln ('Cумма отрицательных элементов: ', min);
end.
- 19.07.2016 18:16
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.