Вопрос по информатике:
Информатики!!! Помогите, срочно надо!! ВОТ ЗАДАЧА:
Пользователь вводит с клавиатуры 3 числа a, b, c , являющиеся сторонами треугольника. Написать программу использующую подпрограмму функцию для вычисления площади треугольника по формуле Герона. (В паскале) Напишите пожалуйста программу
Формула Герона: S=p*(p-a)(p-b)(p-c) (все под корнем). p=a+b+c/2
- 07.12.2017 07:20
- Информатика
- remove_red_eye 2917
- thumb_up 11
Ответы и объяснения 1
Var
p,x,y,z:real;
function s(a,b,c:real):real;
begin
p:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c))
end;
begin
readln(x,y,z);
s(x,y,z);
writeln(s(x,y,z));
end.
- 08.12.2017 20:36
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.