Вопрос по информатике:
Составить программу на языке паскаль, нахождение периметра и площади по трем сторонам( информатик сказал что нужно чтобы можно было выбирать или площадь или периметр)ПОМОГИТЕ ПЖ
Составить программу на языке паскаль по нахождение элементов одномерного массива заданное от 0 до 100
ПОМОГИТЕ ПЖ ДАМ 100 БАЛОВ
- 24.04.2018 22:36
- Информатика
- remove_red_eye 13196
- thumb_up 46
Ответы и объяснения 1
Var
a,b,c,p,s:real;
m:integer;
begin
repeat
writeln('a,b,c &');
readln(a,b,c); {Вводим стороны до тех пор пока не выполнится условие сущ треуг}
until (a writeln('площадь - введите 1 или периметр -2 ?');
{выбираем что считать, если площадь, то вводим 1, периметр - 2}
readln(m);
case m of
1:
begin
p:=(a+b+c)/2;
writeln('S = ',sqrt(p*(p-a)*(p-b)*(p-c))); {вывод площади}
end;
2:writeln(a+b+c); {вывод периметра}
end;
end.
программа 2 Нахождение суммы элементов одномерного массива
const
n=10;
Var
a:array[1..n]of integer;
i,s:integer;
begin
for i:=1 to n do
begin
a[i]:=random(100); {заполнение массива случайными числами [0.100)}
write(a[i]:4); {выводим на экран массив}
s:=s+a[i]; {считаем сумму}
end;
writeln;
writeln('S= ',s); {выводим сумму}
end.
- 25.04.2018 12:47
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.