Вопрос по информатике:
Pascal
Уравнение
Написать программу решения уравнений вида (не обязательно квадратное)
a*X^2 + b*X + c = 0.
Коэффициенты запрашиваются с экрана и могут быть ЛЮБЫМИ действительными числами.
Результатом работы программы является либо вывод корней уравнения, либо вывод
какого-то сообщения. Само уравнение тоже должно быть выведено на экран.
- 09.09.2018 00:59
- Информатика
- remove_red_eye 6853
- thumb_up 8
Ответы и объяснения 1
Program a;
var D,a,b,c: real;
begin
Readln(a,b,c);
//a*X^2 + b*X + c = 0
writeln (a,'*X^2 + ',b,'*X + ',c,' = 0');
D:=b*b-4*c*a;
if (d<0) then writeln ('D<0!') else
if (d=0) then writeln ('X= ',(-b+sqrt(D))/2) else
if (d>0) then writeln ('X1= ',(-b+sqrt(D))/(2*a):0:1,'; X2= ',(-b-sqrt(D))/(2*a):0:1);
end.
- 09.09.2018 11:39
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.