Вопрос по информатике:
Ребята помогите пожалуйста написать программу в паскале " Для заданной квадратной матрицы 6*6 сформировать одномерный массив из ее диагональных элементов. Вывести исходный массив и результаты вычисления."
- 21.12.2017 08:29
- Информатика
- remove_red_eye 7042
- thumb_up 15
Ответы и объяснения 1
Const
n=6;
var
a:array[1..n,1..n]of integer;
b:array[1..n]of integer;
i,j:integer;
begin
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:=random(100);
write(a[i,j]:4);
end;
b[i]:=a[i,i];
writeln;
end;
writeln;
for i:=1 to n do
write(b[i]:4);
end.
вариант главной и побочной диагонали в одномерный массив
const
n=6;
var
a:array[1..n,1..n]of integer;
b:array[1..n*2]of integer;
i,j,k:integer;
begin
writeln;
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:=random(100);
write(a[i,j]:4);
end;
k:=k+1;
b[k]:=a[i,i];
k:=k+1;
b[k]:=a[i,n+1-i];
writeln;
end;
writeln;
for i:=1 to n*2 do
write(b[i]:4);
end.
- 22.12.2017 06:04
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.