Вопрос по информатике:
(Паскаль или Delphi)
Написать программу поиска двухзначных чисел, удовлетворяющих следующему условию: если к сумме цифр числа прибавить квадрат этой суммы, то получится само
число.
- 18.06.2016 00:07
- Информатика
- remove_red_eye 18895
- thumb_up 46
Ответы и объяснения 1
Program z_3;
var a,b,n,s, i: integer;
Begin
repeat
writeln ('Введите Ваше число');
readln (n);
if (n 99) then i:= 0
else i:= 1;
until i>0;
a:= n mod 100 div 10;
b:= n mod 10;
s:= (a+b)+sqr (a+b);
if s n then writeln ('Число не соотвествует условию')
else writeln ('Число ',s, ' соответствует условию');
End.
- 18.06.2016 03:04
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.