Вопрос по информатике:
Пожалуйста помогите с Паскалем
Назовем число палиндромом, если оно не меняется при перестановке его цифр в обратном порядке. Напишите программу, которая по заданному числу K выводит количество натуральных палиндромов, не превосходящих K.
Входные данные
Задано единственное число K (1<=K=<100000).
Выходные данные
Необходимо вывести количество натуральных палиндромов, не превосходящих K.
пс Функции не проходили, надо как то без них
- 17.09.2017 04:09
- Информатика
- remove_red_eye 16808
- thumb_up 37
Ответы и объяснения 1
{L-левая половинка числа, R - правая}
var count,k,m,R,L:longint;
begin
count:=0;writeln('Введите k'); readln(k);
for L:=1 to k do
begin
R:=0; m:=L;
while m>0 do
begin
R:=R*10+m mod 10;
m:=m div 10;
end;
if R=L then count:=count+1;
end;
writeln(count);
end.
- 18.09.2017 21:29
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.