Вопрос по информатике:
Гарри Поттер узнал, в Хогвартсе номера комнат преподавателей делятся без остатка на все свои цифры, в остальных же комнатах живут ученики. Помогите Гарри определить по известному номеру комнаты N (1 Формат входных данных:
Исходный файл содержит одно число N (1 Формат выходных данных:
В выходной файл вывести, букву «T», если в комнате живет учитель (число N делятся без остатка на все свои цифры кроме нуля) или «P» если ученик (число N не делятся без остатка хотя бы на одну из цифр).
- 22.06.2015 16:06
- Информатика
- remove_red_eye 19766
- thumb_up 15
Ответы и объяснения 1
//Это можно стереть. Если в N есть 0 то тогда программа выведет NO.
program z1;
var b,c,d,i,s,l:integer;
a:string;
begin
read(a);
b:=length(a);
s:=StrToInt(a);
c:=0;
for i:=1 to b do
for i:=1 to b do
begin
d:=StrToInt(a[i]);
if d=0 then l:=1;
end;
if l=0 then begin
for i:=1 to b do
for i:=1 to b do
begin
d:=StrToInt(a[i]);
if (s mod d)=0 then c:=c+1;
end;
end
else
write('NO');if (l=0) and (c=b) then write('T');
if (l=0) and (cb) then write('P');
end.
- 23.06.2015 01:31
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.