Вопрос по информатике:
Напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет
посредством цикла WHILE...DO, а вывод – REPEAT...UNTIL (в скобках указана размерность массива):
заменить все элементы массива, которые меньше среднего значения, на «3» (12).
- 01.09.2015 08:56
- Информатика
- remove_red_eye 6899
- thumb_up 30
Ответы и объяснения 1
Const N=12;
var a: array[1..N] of integer;
avg:real;
i:byte;
begin
writeln('Введите массив из ',N, 'элементов');
i:=0; avg:=0;
while i
i:=i+1 ;
read(a[i]);
avg:=avg+a[i];
end;
avg:=avg/n;
i:=0;
writeln('Исходный массив');
repeat
i:=i+1;
write(a[i]:5);
until i>=n;
writeln;
writeln('Отредактированный массив');
i:=0;
repeat
i:=i+1;
if a[i]
until i>=n;
end.
- 02.09.2015 00:06
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.