Вопрос по информатике:
Написать программу, которая проверяет, находится ли введенное с клавиатуры число в массиве. Массив также должен вводится во время программы.
- 26.09.2017 09:13
- Информатика
- remove_red_eye 5675
- thumb_up 18
Ответы и объяснения 1
Const
max= 10; // Количество элементов в массиве
var
a:array [1..max]
i,m:integer;
begin
write('Введите',max,'чисел');
for i:=1 to max do
read(a[i])
write('Введите число');
read(m);
for i:=1 to max do
begin
if a[i] = m
then
begin
write('Это число есть в массиве');
exit
end;
end;
write('Этого числа нет в массиве')
end.
- 27.09.2017 15:01
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.