Вопрос по информатике:
Напишите программу в паскале: найти сумму членов арифметической прогрессии , если известны ее первый член,разность и число членов прогрессии.
- 07.12.2016 21:21
- Информатика
- remove_red_eye 1939
- thumb_up 43
Ответы и объяснения 2
Program SAP;
var
S, d: integer;
i, N: byte;
a: array[1..255] of integer;
begin
write('Введите первый член арифметической прогрессии: ');
readln(a[1]);
write('Введите разность арифметической прогрессии: ');
readln(d);
write('Введите количество членов арифметической прогрессии: ');
readln(N);
for i:= 2 to N do begin
a[i]:= a[1] + (i - 1) * d;
S:= S + a[i]
end;
writeln('Сумма членов арифметической прогрессии: ', S);
end.
- 08.12.2016 23:14
- thumb_up 48
Var a,b,c,k:real;
begin;
write('Введите первое число прогрессии:');
readln(a);
write('Введите разность прогрессии:');
readln(b);
write('Введите число членов прогрессии:');
readln(c);
k:=((2*a+b*(c-1))/2)*c;
writeln(k);
end.
- 09.12.2016 12:25
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.