Вопрос по информатике:
Задана последовательность из n целых чисел. определить среднее арифметическое отрицательных элементов последовательности.
Написать программу в Pascal.
- 22.09.2018 17:36
- Информатика
- remove_red_eye 14532
- thumb_up 14
Ответы и объяснения 1
Var
a: array[1..100] of integer;
i,n,c,h: integer;
begin
writeln('Введите кол-во элементов последовательности:'); readln(n);
writeln('Введите последовательность:');
for i:=1 to n do
begin
read(a[i]);
if a[i]<0 then
begin
c:=c+a[i];
h:=h+1;
end;
end;
writeln(c/h);
end.
- 23.09.2018 07:20
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.