Вопрос по информатике:
Очень срочно пожалуйста
Напишите программу которая находит среднее арифметическое всех чисел записанных в файле в столбик и выводит результат в другой файл
- 03.02.2018 17:41
- Информатика
- remove_red_eye 15981
- thumb_up 44
Ответы и объяснения 1
Var
n,d,s:longint;
mid:real;
f:Text;
begin
n:=0; s:=0;
Assign(f,'input.txt'); Reset(f);
while not Eof(f) do begin
Readln(f,d);
if not Eof(f) then begin Inc(n); s:=s+d end
end;
Close(f);
Assign(f,'output.txt'); Rewrite(f);
mid:=s/n;
Writeln(f,mid);
Close(f);
end.
- 04.02.2018 16:39
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.