Вопрос по информатике:
Помогите пожалуйста составить программу правильно!!!!!
Вот условие:
Даны два действительных числа X и Y, не равные друг другу. Заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением. Программа должна иметь дружественный интерфейс.
На Паскале
- 10.12.2017 02:29
- Информатика
- remove_red_eye 14092
- thumb_up 18
Ответы и объяснения 1
Var x,y,t:real;
Begin
write('x = ');readln(x);
write('y = '); readln(y);
if x>y then
Begin
t:=y;
y:=(x+y)/2;
x:=x*t*2;
End
else
Begin
t:=x;
x:=(x+y)/2;
y:=x*t*2;
End;
writeln('X = ',x:0:2);
writeln('Y = ',y:0:2);
readln;
End.
- 11.12.2017 04:20
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.