Вопрос по информатике:
Помогите очень нужно
составить программу на языке паскаль сортировка от максимального к минимальному
элементу чисел одновременного массива стандартного числа от -100 до 100
- 14.04.2018 01:42
- Информатика
- remove_red_eye 14667
- thumb_up 48
Ответы и объяснения 1
Var
n,i,j,c:integer;
a:array[1..201] of integer;
begin
writeln('введите колөво элементов массива');
readln(n);
for i:=1 to n do a[i]:=-100+random(201);
writeln('Исходный массив');
for i:=1 to n do write(a[i]:5);
writeln;
for i:=1 to n-1 do
for j:=i+1 to n do
if a[i] begin
c:=a[j];
a[j]:=a[i];
a[i]:=c;
end;
writeln('Отсортированный массив');
for i:=1 to n do
write(a[i]:5);
writeln;
end.
- 15.04.2018 22:51
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.