Вопрос по информатике:
Быстрее, пожайлуста!!! Очень важно!!!
2) Составить программу, которая в целом двумерном массиве (6,3) определяет число элементов больше числа, которое вводится с клавиатуры. Массив сгенерирован с помощью датчика случайных чисел в диапазоне (1,8). Элементы массива вывести на экран построчно
- 19.02.2018 07:01
- Информатика
- remove_red_eye 18821
- thumb_up 34
Ответы и объяснения 1
Var c: array [1..6, 1..3] of integer;
k,n,m,i,j,b: integer;
find:boolean;
begin
writeln('введите число');
readln (b);
randomize;
n:=6;m:=3;
k:=0;
for i:=1 to n do
begin
for j:=1 to m do
begin
c[i,j]:=2+random(6); {не включая 1 и 8}
if (c[i,j]>b) then k:=k+1;
write(c[i,j]:6);
end;
writeln;
end;
writeln('число элементов ', k:7)
end.
- 21.02.2018 00:25
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.