Вопрос по информатике:
Помогите составить программу, которая посчитает сумму натуральных чисел из промежутка от 1 до 100, которые делятся на 17 и сумма цифр, которых не превышает 7. В Паскале.
- 16.06.2015 20:56
- Информатика
- remove_red_eye 16290
- thumb_up 11
Ответы и объяснения 1
{сумма натуральных чисел из промежутка от 1 до 100,
которые делятся на 17 и сумма цифр, которых не
превышает 7. Можно перебором}
var i,s:integer;
begin
s:=0;
for i:=1 to 100 do
if (i mod 17=0) and (i div 10 + i mod 10<7) then
s:=s+i;
writeln(s);
end.
{результат 51}
{
Можно оптимизировать
в цикле изменив for i:=1 to 100 do
на
for i:=17 to 100 do}
{2 вариантө оптимальнее - перебираем только числа кратные 17]
var i,s:integer;
begin
s:=0; i:=17;
while i<=100 do
begin
if (i div 10 + i mod 10<7) then
s:=s+i;
i:=i+17;
end;
writeln(s);
end.
- 17.06.2015 20:22
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.