Вопрос по информатике:
Помогите пожалуйста написать программу в паскале "дано целое число N (>0). Найти наибольшее целое число К, квадрат которого не превосходит N : K^2 <= N. функцию извлечения квадратного корня не использовать. " (используя оператор while) ребята, ВЫРУЧАЙТЕ!!!!
- 23.09.2017 19:47
- Информатика
- remove_red_eye 13650
- thumb_up 20
Ответы и объяснения 1
Var N,k:integer;
begin
writeln('введите N');
readln(N); K:=n div 2;
while k*k>N do
k:=k-1;
writeln(k);
end.
{Возможны и другие варианты}
- 24.09.2017 20:29
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.